Обновление с Ubuntu 8.04 (Hardy Heron) до Ubuntu 8.10 (Intrepid Ibex) для владельцев видеокарт ATI не проходит гладко: при загрузке X Server появляется сообщение об ошибке наподобие этого:

dlopen: /usr/lib/xorg/modules/drivers//fglrx_drv.so: undefined symbol: miZeroLineScreenIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//fglrx_drv.so
(EE) Failed to load module "fglrx" (loader failed, 7)
(EE) No drivers available.

В результате X Server не загружается.

К сожалению, удовлетворительного решения проблемы на данный момент нет, что неудивительно: Intrepid Ibex позиционируется пока только как development branch.

Данная ошибка возникла вследствие того, что Intrepid использует версию X Server, которая еще не считается стабильной. В этой версии разработчики внесли изменения в ABI, вследствие чего и возникла несовместимость с драйверами типа fglrx.

Временное решение — изменить в xorg.conf драйвер с fglrx на ati или radeonhd:

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx""ati"
        Option      "OpenGLOverlay" "off"
        Option      "VideoOverlay" "on"
EndSection

Возможны проблемы с 3D (например, весьма вероятно, что Compiz работать не будет), но Иксы работать будут :-)

Добавить в закладки
  • del.ici.ous
  • Digg
  • Furl
  • Google
  • Simpy
  • Spurl
  • Y! MyWeb
  • БобрДобр
  • Мистер Вонг
  • Яндекс.Закладки
  • Текст 2.0
  • News2
  • AddScoop
  • RuSpace
  • RUmarkz
  • Memori
  • Закладки Google
  • Писали
  • СМИ 2
  • Моё Место
  • Сто Закладок
  • Ваау!
  • Technorati
  • RuCity
  • LinkStore
  • NewsLand
  • Lopas
  • Закладки - I.UA
  • Connotea
  • Bibsonomy
  • Trucking Bookmarks
  • Communizm
  • UCA

Связанные записи

10
Сен
2008

Комментарии к статье «Ubuntu Intrepid Ibex и драйвера на видеокарту ATI» (10)  »

  1. SaltyDog says:

    уже 8.10 доступна? я, кажется, еще только беты видел..
    а вообще ати под никсами это зло, тут самый универсальный производитель - интел, поскольку предлагает сам открытые драйверы, а не костыли, которые юзеры из глубинки пишут по спекам.

  2. Vladimir says:

    уже 8.10 доступна?

    Если сделать do-release-upgrade -d, то да :-)

    а не костыли, которые юзеры из глубинки пишут по спекам

    А проприетарные атишные дрова имеют те же самые проблемы :-)

    Вообще в комментариях к багу сказано:

    There is nothing that we can do at this point other than wait for an updated driver

    и

    I’ve been in contact with AMD on this issue. I can confirm the issue exists with xserver 1.5 on all versions of -fglrx and is in process of being worked on.

    Some technical background - xserver 1.5 includes a rework of how private server data is handled, which has necessitated updates in all FOSS drivers. -fglrx is being updated to account for this change, but I understand it is not a trivial amount of code to fix.

  3. DimoninG says:

    Обычно с ATI проблемы всегда. У меня сколько их карточке не побывало - всегда были какие-то косяки с установкой дров. Особенно были косяки с установкой дров на ноутбук (тоже АТИ), там вообще все слетало непрогнозируемо.

  4. Vladimir says:

    Да вроде как вышел апдейт на fglrx, но мне перезагружаться лень, чтобы проверить :-)

  5. Спамер-автомобилист says:

    Some technical background - xserver 1.5 includes a rework of how private server data is handled, which has necessitated updates in all FOSS drivers. -fglrx is being updated to account for this change, but I understand it is not a trivial amount of code to fix.

    Точно:)

    Автомобилист, спам не пройдет. Все комментарии премодерируются специально натренированной обезьянкой.

  6. Vladimir says:

    Что характерно: вчера вышла новая версия пакета fglrx-kernel-source (2:8.532-0ubuntu1), сегодня вышла еще одна (2:8.532-0ubuntu2); причем, насколько я могу судить, они с открытым кодом. Но, что характерно, ни одна из версий так и не скомпилировалась:

    Error!  Build of fglrx.ko failed for: 2.6.27-3-generic (x86_64)

    В связи с чем возникает вопрос: как они там всё тестируют? :-)

  7. Vladimir says:

    …и сегодня еще одна появилась (fglrx-kernel-source 2:8.532-0ubuntu3); но даже она с проблемами:

    Error! Application of patch fglrx_8.9_2.6.27.patch failed.

    При этом я использую официальную версию ядра (2.6.27) для релиза 8.10. Фантастика! :-)

  8. Vladimir says:

    Я знал, я верил! :-)

    Сегодня наконец-то появился драйвер (fglrx-kernel-source 2:8.532-0ubuntu4), который DKMS смог нормально собрать!

    10 дней, не так уж и плохо :-)

  9. EvilFaeton says:

    И что работает?
    Я сегодня обновился до беты 8.10. Итого: fglrx не встает никак (ни через envy, ни через apt-get, ни даже не через ручную сборку fglrx_installer), дело как я понимаю в том что frlrx не поддерживает xorg 7.4 - при установке fglrx-driver apt мне радостно предложил удалить несколько пакетов в том чилсе - ubuntu_desktop и xorg. :)

  10. Vladimir says:

    Со старым xorg (из Hardy) — работает. С новым работать не будет. Я так понимаю, что пока 8.10 не станет стабильной, ATI не будет переписывать драйвера.

Подписаться на RSS-ленту комментариев к статье «Ubuntu Intrepid Ibex и драйвера на видеокарту ATI» Trackback URL: http://blog.sjinks.org.ua/linux/333-ubuntu-intrepid-ibex-and-ati-drivers/trackback/

Оставить комментарий к записи «Ubuntu Intrepid Ibex и драйвера на видеокарту ATI»

Вы можете использовать данные тэги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Оставляя комментарий, Вы выражаете своё согласие с Правилами комментирования.

Подписаться, не комментируя