Eclipse Ganymede: Cannot connect to keystore

Vladimir
Опубликовано в: Linux

Если при установке C/C++ Development Tools (CDT), PHP Development Tools (PDT) или любого другого пакета возникает ошибка:

An error occurred during provisioning
Cannot connect to keystore

Это означает, что выбрана не та версия виртуальной машины Java. Далее

23
Сен
2008

Сегодня столкнулся с очень неприятной проблемой: старая инсталляция Eclipse PDT не пошла на моей Ubuntu 64-bit. Eclipse 64 у меня нормально не пошла: я, конечно, слышал, что она глючная, но не верил. Теперь верю. Промучавшись пару часов и так и не найдя решения, я полез в Google (благо Google меня еще не забанил).

Всё же, благодаря Дэну Мартину, решение было найдено.

Dan, if you read this, thank you very much — you literally saved my life!

В надежде, что не я один такой, привожу перевод оригинальной статьи с небольшими изменениями. Далее

12
Июль
2008

Симптом: при запуске Eclipse появляется окошко вида:

Лечится просто:

[-]
View Code Bash
mkdir -p ~/.mozilla/eclipse
7
Май
2008